Jump to content

Recommended Posts

Tiens moi aussi ça m'énerve !

 

B****l mes fichiers Max mettent 5-10min à s'ouvrir....

 

Certains projets sont certes lourd, mais je bosse en proxy...

Textures souvent HD certes...

J'utilise la commande FreeSceneBitmaps() de temps à autre mais bon...

 

Comment supprimer facilement les shaders inutilisés ? A la main ?

 

J'utilise aussi le script Cleaner qui marche pas trop mal mais je vois pas la différence...

 

Je bosse sur un Dell bi Xeon 2620 16Go de Ram et Quadro 4000, le tout sur SSD.

 

Merci d'avance pour vos idées ! :)

Share this post


Link to post
Share on other sites

Tu sais, ça me fait pareil moi aussi avec certaines scenes et pas d'autres, jamais pigé pourquoi.

Pareil que toi, j'ai beau passer des scripts comme Teague Scene Checker, Cleaner etc ... parfois il n'y a rien à faire.

J'imagine que tu as déjà essayé de partir d'une scene vide et de tout merger ?

Share this post


Link to post
Share on other sites

Ben y a plusieurs choses en faite

 

Dans l'éditeur en mode slate il est inutile de laisser tous les matériaux dans l'espace central, les matériaux appliqué sont sur les objets, donc juste quand tu les crées

Ensuite tous ceux qui sont dans le "sample slots" si tu l'utilise tu peux les virer mais en passant par l'ancien éditeur, le compact et la tu fais utilities --> Reset Material Editor Slots

 

Ceux qui sont appliqué tu peux les virer aussi puisse que tu peux toujours les récupérer

Share this post


Link to post
Share on other sites

pourmoi cela fonctionne, mais c'est pas en auto, je veux dire par la que si tu va ds ton espace detravail ou autre faut revenir selectionner le mode d'incrust pour povoir le faire defiler "a la roulette"...

Logique, c'est lié au focus des controls, donc si tu es sur ton espace de travail, le focus n'est pas sur le selecteur...

Share this post


Link to post
Share on other sites

Ok, c'est bien mieux merci !

 

Bon allé j'avoue, je me mets à utiliser les calques là car ça devient le b****l dans ma scène. mais une fois un calque "hide", comment faire pour qu'il se calcul qd même au rendu ? Avec la théière ON ou OFF ça marche pô... je dois être bête.

Share this post


Link to post
Share on other sites

Salut,

 

Il était temps!!!!  :mrgreen:  :mrgreen:

 

Alors si tu veux que ça fonctionne comme ça il faut que dans tes préf de max, tu sois en mode "by layer" pour le propriétés d'objet et pas en mode "by objet"

Donc dans customize--> preferences... -> general --> voir ma capture d'écran

 

post-92-0-83155300-1427449394_thumb.jpg

 

 

Edit :

Perso j'utilise les calques mais ceux que je "hide" ils restent "hide" pour mon rendu! Car tu pourrais te planter !! Ensuite c'est quoi ton but ? Aléger ton viewport? Alors il y a d'autre méthode A mon avis ;-)

Share this post


Link to post
Share on other sites

Xref.... 

 

Tu sélectionnes tes éléments et tu les fais devenir xref

menu principal ->reference -> scene Xref et la une fenêtre apparait et tu fais convert selected, ca devient une scéne max que tu peux ouvrir indépendament et travailler dedans et tu peux l'activer ou pas  

Share this post


Link to post
Share on other sites

C'est ça: en fait, tu ne "convertis" pas une scene en XRef (c'est pas comme un proxy). Tu l'enregistres dans une scene à part, et tu appelles cette scene dans ta scene principale. Le gros avantage c'est que à allège ta scene pricnipale: elle pèse beaucoup moins car la géométrie n'est pas stockée dedans mais dans le fichier XRef. Et après, oui tu peux afficher ta scene Xref sous forme de simple Box mais elle sera quand même rendue au calcul. Tu peux aussi carrément la désactiver, et dans ce cas elle ne sera pas rendue :)

Share this post


Link to post
Share on other sites

Mais je peux plus sélectionner mes Xref la... Pour les mettre en Box c'est où ? Ya rien dans Manage xref....

 

 

???? y pas de "manage xref" mais un "Xref scene" et un "manage links" :-) ne te mélange pas les pinceaux

 

Donc +1 avec Thomas 

 

Tu peux aussi ne pas la voir du tout cad l'activer mais pas l'afficher et elle sera rendue (Display option ... rien de cocher)

 

edit:

un peu comme ton calque que tu "hide" mais qui est rendu!

Share this post


Link to post
Share on other sites

Normal: Manage Links ne sert pas pour les XRefs mais pour lier des fichiers d'autres applications (AutoCAD, Revit) à intégrer à ta scene 3dsmax.

Pour gérer les XRefs de ta scene principale, va dans File > XRef Scene ...

Ensuite clique sur Add ... pour ajouter la scene que tu souhaites définir comme XRef et choisis ensuite les options d'affichage: Visible (ou pas), Box (ou pas) etc ...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Who's Online   0 Members, 0 Anonymous, 26 Guests (See full list)

    There are no registered users currently online

×
×
  • Create New...