Jump to content
XYZ

rendu 5000x5000 ou plus

Recommended Posts

Bonjour à tous

Je me lance sur un petit rendu qui avoisinera les 5000 x 5000 (ou 6000 )

je suis un habitué des petit rendu 2000 x 2000 en gros ...

 

Je voulais savoir dans quel mesure modifier les réglages de notre ami V-ray.

 

la scène est simplette un peu de gazon un bâtiment centré, une HDRI et un sun . ni plus ni moins

 

irradiance map + light cache 

IR en custom -3 - 1  subdivs a 60

light cache subdivis 2500 ...sample size 0,008 (too much il me semble )

V-RAY en adaptive a 1- 4

 

j'ai lancé un petit calcul hier soir et il est largement resté planté sur le light cache.

 

Ce que je n'arrive pas à manipuler correctement c'est  l’écart entre  un rendu de 1500x 1500 qui prend une heures avec ces réglages, donc rien d’alarmant  et le faite qu'en 5000 x 5000 ...eh bien paf ..plus personne :) ...

 

si jamais une bonne âme.....:)

Share this post


Link to post
Share on other sites

Hello,

 

Déjà, tu peux baisser ton IrrMap, genre -4 -2 je pense.

Le Sample Size à 0.008 me semble vraiment bas, même pour du 2000. Ne pas oublier qu'il s'agit d'un pourcentage de la largeur du rendu: 0.01 correspond à 1%. Pour du 5000, çà ne me semblerait pas déconnant de le mettre à 0.04 ou 0.05. C'est le genre de valeur que je mets pour du 10 000 de large. A confirmer cependant ;)

Ce n'est généralement pas une bonne idée de se dire: mes réglages fonctionnent avec telle résolution, çà va marcher avec telle autre, plus grande. Que ce soit les prepass de l'IrrMap ou le Sample Size du LC, les paramètres sont liés à la résolution !

Share this post


Link to post
Share on other sites

merci Nicolas !! 

 

je suis d'accord avec toi pour ne pas "figer" des réglages vis à vis d'une reso

Après c'est vrai que, bon, de jours en jours, j'ai pris de mauvaises habitudes, un peu de fainéantise aussi.

Tu sais que ta scène est comme une précédente et bon ...ba....

 

donc d’après mon light cache peut rester à 2500 et passer a 0.04 ....

j'ai peur que cela replante au niveaux du calcul du lightcache ....la c’était quand même encore en calcul au bout de 5 heures !!!

baisser les subdivis peut etre ? (elles sont a 2500 ) ....

Share this post


Link to post
Share on other sites

merci Nicolas !! 

 

j'ai peur que cela replante au niveaux du calcul du lightcache ....la c’était quand même encore en calcul au bout de 5 heures !!!

baisser les subdivis peut etre ? (elles sont a 2500 ) ....

Difficile à dire sans voir la scène. Les raisons peuvent être multiples ... as-tu testé avec un Global Material Override en blanc (genre 220 / 220 / 220) ? çà peut être un souci de matériau, un displace trop élevé, des blanc purs (pas de 255/255/255 !!!) etc etc

Share this post


Link to post
Share on other sites

je vais me faire un test en override.

tu pense quil faut le faire idem a 5000x5000 ? 

 

sinon ma scène sort correctement en 1500x1500. si il y avait un problème de textures ou autre je le verrai non ?

est-il possible qu'un problème naisse uniquement à une grande résolution ?

Share this post


Link to post
Share on other sites

euuuu

 

Genre, un problème de RAM ? :P

Tu es bien en Scale "Screen" et non pas "World" pour le LC ? le mode "World" est plus adapté dans certains cas, mais bouffe plus de RAM.

pour la RAM j'ai 32 go ça devrai aller ....(j’espère :) )

 pour le scale je suis en screen ....voui voui

Share this post


Link to post
Share on other sites

une question simple .....

pour le LC baisser le nombre de subdivis ....qui est a 2500 c'est une hérésie ?  par exemple le passer à un brave 1200 des familles....

 

sachant que mes subdiv des lights sont hautes et que celles des mat avec réflexion le sont aussi ... (si rapport il y a  ...) :?

Share this post


Link to post
Share on other sites

1200 pour le LC, çà me semble un peu bas pour de l'image finale, mais bon ... çà peut aider pour de la très haute déf, même si j'aurais tendance à plutôt jouer sur le Sample Size (à tort peut-être).

çà peut avoir une incidence si tu as coché l'option "Use For Glossy Rays"

Share this post


Link to post
Share on other sites

il est coché en effet ...

tu pense que c'est a décocher ? ..

il passe trop de temps à calculer une light cache pour les rayon brillant ? ...les réflexions ?

Non, pour autant que je sache, cette option peut rester cochée. Elle est supposée accélérer un peu le calcul des glossy effects (soft shadows, blurry reflections & refractions ...). En tout cas, çà ne m'a jamais posé problème de la laisser activée.

Share this post


Link to post
Share on other sites

mais il est fais :) le test

en 2000x2000 et rien ne bouge pas de souci aucun !!

25 min de calcul et c'est tout ....tout ça passe bien

je vais essayer de lancer un 5000x5000 à midi voir si au moins le light cache passe pour cette dimension ...

 

 

Après il y a le pre filter du light cache qui est activé ...peut être une étape en trop ..

Share this post


Link to post
Share on other sites

c'est noté !!

donc pour résumer pour un test de 5000x5000 (juste pour voir si le light cache passe) :

je passe mon LC a 2500

puis mon sample size a 0.04

le pre filter à 20 (nearest inter.S à 5 )

 

 

eh pis c'est tout !

si je vois qu'en une heure de pause déjeuner le light cache est à la ramasse ....je sulfate  :)

Share this post


Link to post
Share on other sites

Salut XYZ,

 

Nicolas et lolonic t'ont déjà mis sur le bon chemin je pense. Un truc qui aide bien aussi: pour ton gazon et tes plantes si il y en a, passe les "GI Subdivs multiplier" à 0.1 voire 0.05 même, ça baisse franchement les temps de rendu et la différence au final est faible car la GI sur la végét a peu d'importance la plupart du temps. Inversement, là où tu as besoin de plus de précision en GI, typiquement les murs et les plafonds mais c'est plutôt sur des vues d'intérieur, tu peux passer cette valeur à 2 voire 3 si des tâches apparaissent sur ta GI.

Share this post


Link to post
Share on other sites

Salut XYZ,

 

Nicolas et lolonic t'ont déjà mis sur le bon chemin je pense. Un truc qui aide bien aussi: pour ton gazon et tes plantes si il y en a, passe les "GI Subdivs multiplier" à 0.1 voire 0.05 même, ça baisse franchement les temps de rendu et la différence au final est faible car la GI sur la végét a peu d'importance la plupart du temps. Inversement, là où tu as besoin de plus de précision en GI, typiquement les murs et les plafonds mais c'est plutôt sur des vues d'intérieur, tu peux passer cette valeur à 2 voire 3 si des tâches apparaissent sur ta GI.

 

Merci Thomas

Je la fais quasi systématiquement  en effet .. merci d'ailleurs  pour cette petite manip posté sur le blog de matt

 

bon le mystère reste entier  après plusieurs test

un LC à 1500 sample size a 0,01 (je revenu à la base)

 

1000 X 1000  = LC nickel pas de problème

2000 X 2000 = LC nickel pas de problème

3000 x 3000 = LC nickel pas de problème

4000 x 4000 = Gros merdier

 

j'ai "building embree statics accelerator qui brode et hop je passe à "ne répond plus .."

 

évidement le "use embree est enclenché et la valeur de 30 000 est entrée sachant que j'ai 32 go de RAM .

 

là je dois avouer que je sèche ...

Share this post


Link to post
Share on other sites

Quelque chose dans ta scene fait bloquer VRay: soit un render settings, des subdivs de light ou de Mtl ... Procède pas à pas: pars direct sur ta résolution finale 4k mais commence par mettre toutes les subdivs Mtl et lights à des valeurs très basses genre 3 pour les light et 8 pour les mtl. Désactive le displace et prend un Mtl override. Fais ton rendu et vois ce qu'il se passe. Si c'est ok --> active progressivement les options high quality pour tous ces paramètres jusqu'à voir qui est le coupable. Sinon,si déjà là ça bloque, il y a quelque chose de pas clair dans ta scene (géométrie importée ? overlappipng faces ? ...): cache tous tes layers puis unhide les un par un jusqu'à trouver celui en cause.

Share this post


Link to post
Share on other sites

Et au cas où tu aies des objets de provenance variée:

BadRaytrace = getClassInstances raytrace
for R in BadRaytrace do replaceInstances R (falloff name:R.name)

Mais bon, çà m'étonnerait que ce soit un souci de matériau, sinon tu aurais le même souci indépendamment de la résolution de sortie.

Share this post


Link to post
Share on other sites

Tu as fait un VRay scene converter ? Reseté VRay aux default settings ?

Vray scene converter ?? euu non ? ...

reset au vray de defaut oui cest fais !

 

 

Dernière question: tu aimes les films de gladiateurs ?

Ok, je retourne (essayer de) bosser :P

je n'ai pas tout pigé desolé Nico ... :?

 

 

Tu as essayé en décochant Embree ? sur certaines scène, inexplicablement, çà nous a foutu la merde. Une fois Embree décoché, tout roulait. çà reste malgré tout très rare ...

c'est noté

 

Je procede au test indiqué par Thomas, et je vous tient au courant. ..

Pour le moment ovedrive en 4000X 4000 tout va bien je vais exclure de l'overdrive chaque élément un à un ...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Who's Online   0 Members, 0 Anonymous, 37 Guests (See full list)

    There are no registered users currently online

×
×
  • Create New...