Jump to content
TChadail

Problème avec les groupes

Recommended Posts

Bonjour,

 

Dans max 2016 je rencontre un problème qui n'existait pas sur les précédentes versions de max: je fais une box, je la duplique en copie, je groupe les 2 puis je fais un scale disons de 150% sur ce groupe. Jusque là, pas de souci, mais, si je dégroupe les box, leur échelle est de 100% et non 150 ...

Share this post


Link to post
Share on other sites

Ne jamais utiliser l'outil Scale en mode objet (pas de souci en mode sous-objet). Privilégier le modifier XForm, qui est justement fait pour "injecter" des transformations en tant que modifications dans la pile des objets. Si tu utilise l'outil Scale sur un groupe, tu transforme le groupe + ses membres, donc si un membre sort du groupe, la transformation ne s'applique plus à lui, c'est logique. D'où l'intérêt (l'obligation ?) de passer par des modifications et non pas des transformations dans des cas comme celui-ci.

L'outil Scale + les groupes = recherche de problèmes ;) le Scale tout seul est déjà un bon moyen d'avoir des mauvaises surprises (cf blog de ce bon vieux Ted Boardman).

Share this post


Link to post
Share on other sites

Oui je parlais de l'outil Scale.

Si je dégroupe et que je mets un XForm sur les boites, il ne se passe rien.

Hmm ... j'ai l'impression que tu ne t'y prends pas correctement. 

- Groupe tes box

- applique un XForm au groupe.

- mode sous-objet, et là tu transforme le gizmo (si tu reste en mode objet, c'est évidemment comme si tu n'avais pas ajouté de XForm)

- Repasse en mode objet

- Ouvres ton groupe et détache la box du groupe -> pas de souci

Share this post


Link to post
Share on other sites

Merci beaucoup pour ta patience et tes explications Nicolas: j'y vois bien plus clair. Il n'est jamais trop tard pour prendre de bonnes habitudes de travail !

Ce qui m'étonne c'est que je n'ai jamais eu ce genre de problème avec les anciennes versions de max: ça se passait toujours très bien en employant directement l'outil Scale, donc sans utiliser le modificateur XForm.

En tout cas mon problème est résolu :)

Share this post


Link to post
Share on other sites

En tout cas ton problème est bizarre, je viens d'essayer ta manip sur max 2014 et max 2016 et j'ai le même résultat sur les deux, mes box ont bien un scale (disons 150%) après les avoir dégrouper...

Share this post


Link to post
Share on other sites

En tout cas ton problème est bizarre, je viens d'essayer ta manip sur max 2014 et max 2016 et j'ai le même résultat sur les deux, mes box ont bien un scale (disons 150%) après les avoir dégrouper...

 

Ah on est d'accord ! Comprends pas pourquoi mon max réagit comme ça --> réinstall en vue

Share this post


Link to post
Share on other sites
La box a bien le scale mais pas dans c'est information de dimension si la boite à 100 X 100 X 100 si tu fais un scale et bien la boite est plus grande mais les infos de dim son 100 X 100 X 100!!

 

 

Euh attention, ça c'est vrai lorsque tu regardes les transformations locales, pas celle en world !

Share this post


Link to post
Share on other sites

Bonjour,

 

Je viens de tester la manip sur 2016 sans rencontrer de problèmes.

Sur la version SP2 de 2016 il y avait un énorme bug de groupe et de contraintes (lors du dégroupage ou du "delink" tout partait en sucette si on avait appliqué des "mirror" et des scales divers...)   qui vient d'être corrigé avec la SP3, à mon avis ton problème vient de là.

Pour moi la SP2 était inutilisable en prod, j'avais du repasser en SP1 mais avec la SP3 tout est nickel, max 2016 est top !

 

 

mienda

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Who's Online   0 Members, 0 Anonymous, 12 Guests (See full list)

    There are no registered users currently online

×
×
  • Create New...