Jump to content
Sign in to follow this  
ADA

Problème animation

Recommended Posts

Bonjours, 

 

Me voila dans un cul de sac ça fais deux jours entiers que je tourne en rond ...  :wacko:

 

Pour introduire le sujet, je travail sur deux villas traiter comme des lodges. Je me suis inspirer de Marcio Kogan pour faire un systeme d'ouverture et de fermetures avec des volets/clostras qui font tout le tour des lodges : 

post-2098-0-66311800-1472231071_thumb.jpegpost-2098-0-97968500-1472231071_thumb.jpgpost-2098-0-23927600-1472231072_thumb.jpg

 

Seulement voila, je pense que mon client ne comprendras pas forcement la force de ce genre de volets, si je lui fais seulement des images fixes. (Avouez que je suis de bonne volonté  8-)  ) 

Cependant, n'ayant jamais fais d'animation me voila à galeré a ecouter des tuto en indiens mais rien n'y fais, ma bonne volonté ne suffit plus, je deviens fou cependant je sens que je touche presque au but.

Voila ce que j'aimerais vraiment faire : 

Voila ce que j'arrive seulement à faire, j'arrive a peu prés a les linker, les rigger, ... ect mais impossible d'etres sur le meme axe Y, comme si les volets suivés un rail ...:

https://gyazo.com/9ebeb727e8f79a29d7c232865fd0906a

 

Ps : Je commence à en perdre des cheveux

Merci, pour j'espère vos futures éclaircissements, 

 

En éspérant ne pas perdres tout mes cheveux d'ici là,

je vous souhaite un bon week-end.

 

Théo

Share this post


Link to post
Share on other sites

Salut, 

 

 

Tu travailles sur quel version de max ?

 

Je travaille sur Max 2015, cela aurais t'il un impact sur ma galère ? 

 

 

hello,

 

Il doit bien y avoir un script sur scriptspot pour ça, non ;)

Sinon 2sec de google

 

celle-ci m'a l'air pas mal :

 

edit : attention de partir avec un bon pivot

 

++

 

Et non, je n'ai rien trouvé sur scriptspot, ou alors j'ai peut etres mal cherché,

comme ça a étais le cas avec notre ami google...

 

Je m'y remets, je sens qu'avec ces pivots je vais perdre encore quelques cheveux

Share this post


Link to post
Share on other sites

bah la meilleur soluce pour moi c dabord de linker t porte et ensuite d'utiliser le wire parameter et de linker la rotation z des porte entre elles (ex: rotationz->rotationz*(value(tu met ce qui te semble le mieux)))

Attention de bien faire une connection one way, tu peut ensuite crée des null histoire de rendre tout ça un peut plus user friendly ^^.

 

(tu te crée un null, tu le sélectionne, alt+1 pour ton éditeur de paramètre, tu le crée un nouveau paramètre (met un nom et utilise float) ensuite tu wire ton nouveau paramètre a ta valeur rotate Z de la 1ere porte).

Si tu galère je peut te faire une scène rapido si tu veux .

 

Ah et comme l'a dit miaz place bien t pivot :)

Share this post


Link to post
Share on other sites
Je travaille sur Max 2015, cela aurais t'il un impact sur ma galère ? 

 

Non c'était juste histoire de te faire une scène d'exemple rapidos...

 

Mais avec les explications que tu as eu, ça devrait suffire j'imagine :)

Share this post


Link to post
Share on other sites

+1 pour l'utilisation de dummies / null

ouai c toujours plus sympa ^^, le truc que j'aime bien aussi avec max c utiliser les spline (ex un cercle) cocher render in viewport lui coller une couleur pas trop moche, un resetXform et hop ça te fais un jolie controler XD.

Share this post


Link to post
Share on other sites

Merci pour vos réponses, je sens que j'y arrive mais je galère encore... je vais vraiment finir chauve je crois 

 

Aprés avoir bien placé mes pivots, ect... me voila bloqué de nouveau, sa aurais été trop simple sinon 

 

On ne peut changer les wire paramètres d'un groupe ? Car mes volets sont constitutés d'un cadre, de lattes de bois, de charnieres, de vis qui tiennent les charnieres. Je suis obligé de faire un editpoly avec des ID différentes pour chaques éléments ?

 

bah la meilleur soluce pour moi c dabord de linker t porte et ensuite d'utiliser le wire parameter et de linker la rotation z des porte entre elles (ex: rotationz->rotationz*(value(tu met ce qui te semble le mieux)))

Attention de bien faire une connection one way, tu peut ensuite crée des null histoire de rendre tout ça un peut plus user friendly ^^.

 

(tu te crée un null, tu le sélectionne, alt+1 pour ton éditeur de paramètre, tu le crée un nouveau paramètre (met un nom et utilise float) ensuite tu wire ton nouveau paramètre a ta valeur rotate Z de la 1ere porte).

Si tu galère je peut te faire une scène rapido si tu veux .

 

Ah et comme l'a dit miaz place bien t pivot :)

 

Au risque de paraitres idiot,  qu'entend tu par null ? ce sont des points helpers ? 

 

Ci-joint : Le fichier max de mes volets pour mieux visualisé l'objet à mettre en mouvement, si besoin

Share this post


Link to post
Share on other sites

Bon ba j'ai abandonné les groupes, en créant à la place des editpoly avec matID mais je n'y arrive toujours pas...

 

Aprés avoir bien remis mes point de pivot et linker mes volets :

 

post-2098-0-49542200-1472657640_thumb.png

 

Quand je fais wireparameter - rotation Z  : 

 

post-2098-0-74188200-1472657788_thumb.png

 

Voila ce que sa me donne : 

 

post-2098-0-88006300-1472657819_thumb.png

 

et si j'enchaine le wireparameter sur les autres volets comme dis dans les tutos : 

 

GIF : https://gyazo.com/e43985ea476465f08e87e66b505de25c

 

Je ne sais plus quoi faire, je dois surement avoir du louper quelque chose mais quoi ? 

 

Voici la scène avec les volets, (Linker et wire en rouge, original en gris), si jamais vous voulez jetez un coup d'oeil :

https://we.tl/gm6AJs3MiR

 

Share this post


Link to post
Share on other sites

Ca y est, aprés 4 jours à tout tourner dans tout les sens, j'ai reussi ! enfin, je vais pas récolter tout les lauriers vous y etes grandement pour quelque chose, merci !

 

Le probleme étais simple mais bizarre, il s'agisait de la commande du wire parameter : Au lieu de mettre -Z_rotation*2 il suffisait d'enlever le négatif et mettre Z_Rotation*2.

 

GIF : https://gyazo.com/6149a71c5db80e0088948b1a0ff52214

 

Ps : il me reste quelque cheveux sur le caillou

Share this post


Link to post
Share on other sites

J'étais satisfait, j'ai reussi sur un mais les autres impossible.

 

J'ai trouvé la source du probléme (je crois :ugeek: ) mais je ne trouve pas de solution...

Je n'arrive pas aligner les pivot sur le même plan.

Je m'explique, les axes X et Z sont parrallèle et dans la même direction tandis que mon axe Y est parrallèle mais pas dans le même sens... 

 

post-2098-0-31635300-1472743413_thumb.png

 

Cependant, j'ai essayé d'aligner le pivot ( avec le y dans la mauvais direction) avec le pivot ( ou tout est dans le bon sens) avec la commande align, mais à chaque fois, c'est soit le X, soit le Y, soit le Z qui se retrouve dans la mauvaise direction...

 

GIF : https://gyazo.com/35406ecb2f044132449e23b8537ae4fb

 

J'ai essayé aussi de l'aligner "to world" mais la sa me l'inverse :

 

post-2098-0-04125300-1472743687_thumb.png

 

Alors, j'en suis venus a l'idée que c'étais parceque mon deuxième volet (celuil de droite) étais un mirroir du premiers et donc qu'il avais aussi fais le mirroir sur le pivot mais bon, je sais pas car j'ai quand même réussi a le faire avec les plus grand volets et j'ai répéter le même principe sur les autres donc bon ... voila, je suis perdu 

 

 

 

Avez vous une petite idée d'ou le problème vient et comment le réparer

 

Share this post


Link to post
Share on other sites

Tu peux dire merci à l'outil Mirror de 3dsmax ... il est à éviter comme la peste, parce qu'il revient à faire un scale à -100% sur un axe  :? de mémoire, çà a été résolu dans 3dsmax 2017, mais c'est à confirmer (la résolution de ce souci est restée longtemps dans le top des Small Annoying Things).

Privilégie l'utilisation des modifiers Mirror ou Symmetry, tu n'auras pas le souci.

Share this post


Link to post
Share on other sites

Oulala popol, dur XD

Pour la traduction, il voulait dire n'oublie pas de reset (et au passage de freeze) toutes tes transforms avant quoi que ce soit :)

 

Sinon, de manière un peu plus globale, je te conseillerais vraiment de creuser un peu plus le rigging et l'animation avant de vouloir te lancer sur une prod comme ça...

Quand je vois que tu utilises des groupes, des miroirs, etc... je me dis que tu n'as pas du tout les bases, et que si pour le coup ce que tu veux faire ici reste assez basique, la prochaine fois tu risque de galérer beaucoup plus...

 

Pour info, je te conseille les cours de Paul Neale (y'en à pas mal sur youtube)

Share this post


Link to post
Share on other sites

Aprés avoir utilisé le transformer mirror et de l'avoir collapse l'animation marche bien sur mes trois types de volets différents, merci.

Reste à intégrer les animation dans ma scène principale.

Je vous tiens au jus  :)

 

Sinon, de manière un peu plus globale, je te conseillerais vraiment de creuser un peu plus le rigging et l'animation avant de vouloir te lancer sur une prod comme ça...

Quand je vois que tu utilises des groupes, des miroirs, etc... je me dis que tu n'as pas du tout les bases, et que si pour le coup ce que tu veux faire ici reste assez basique, la prochaine fois tu risque de galérer beaucoup plus...

 

Pour info, je te conseille les cours de Paul Neale (y'en à pas mal sur youtube)

 

Effectivement, je ne connais rien à l'animation et apprendre sur le tas c'est toujours comme ça que j'ai fais mais effectivement des fois les bases me manque mais bon j'apprends de mes erreurs et grâce à vous.

En tout cas merci pour les conseils et pour les cours de Paul Neale, je vais creuser ça.  :mrgreen:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Who's Online   0 Members, 0 Anonymous, 18 Guests (See full list)

    There are no registered users currently online

×
×
  • Create New...