Aller au contenu
pixelo

Animation avec moving objects : Flickering + lenteur

Recommended Posts

bonjour à tous,

J'essaie de faire une anim avec des moving objects mais je m'arrache les cheveux.

J'applique la méthode du tuto, mais ca flicke dans les ombres malgré des temps de calcul assez elevés.

Ci-joint mes settings:

post-974-1349425380503_thumb.jpg

post-974-13494253807053_thumb.jpg

Avec ces réglagles, le calcul des irmaps est rapide, environ 3 à 4 minutes par frame, mais le rendu prend 30 minutes par frame, et meme jusqu'a 1h pour les 5 dernières frames calculées (bizarre une telle différence ? peut-être parce que la camera se met a bouger à la frame #20 ? Très étonnant...).

Et quand je fais le rendu d'une frame avec exactement les meme settings, juste "From File" pour l'IRMAP au lieu de "Animation (Rendering)", le temps de calcul descend a 8 minutes (en mettant "Single Frame", idem, 8 minutes)...

Je veux bien croire que la qualité ne soit pas super avec seulement 8' de calcul par frame, mais comment expliquer que le fait d'interpoler 5 frames d'IRMAP (interp. frams = 2) multiplie le temps de calcul par un facteur 4 à 8 ?

Si quelqu'un a une idée, je serais très reconnaissant car je commence a franchement désespérer.

Merci !

Share this post


Link to post
Share on other sites

Salut,

Il y a beaucoup de choses qui ne vont pas dans tes paramètres... On va pas se faire toute la liste, il y en a beaucoup trop. On va plutot la faire dans l'autre sens et reprendre a zero.

. Remets Vray a zero et ne touche a rien d'autre que ce que je te dis, t'as touche trop de valeur sur cette scene ^^

. Fais un setup correct de ton LWF (ni subpixel, ni clamp)

. Utilise le preset medium anim (sans toucher à hsph et interp)

. Lance ton pre-calcul en mode anim-precalc

. Utilise le preset anim render et passe ton go ^^

Le fait de trop toucher a tout sans trop savoir t'as plante:

. l'enviro actif mais vide et a 0

. le sampling demesure...

. le dmc sampler completement hs...

Comme je dis souvent, avec Vray vaut mieux ne pas toucher un paramètre que mettre un truc au pif ;)

Share this post


Link to post
Share on other sites

Bonjour,

Et merci pour ta réponse !

j'ai suivi tes conseils et ça va beaucoup mieux ainsi. Je vais faire un rendu de test et poster les résultats.

En attendant je me suis rendu compte d'un truc très bizarre. J'ai fait des tests de rendu en demi-résolution avec différentes valeurs de "interp. frames". Voici les temps de rendu que j'obtiens (sans compter la prepass) :

iF = 2 : 1'50

iF = 3 : 2'14

iF = 4 : 2'46

iF = 5 : 13'00 !

En utilisant les mêmes fichier IRMAP et tous les autres paramètres identiques bien sûr. Etonnant de voir le temps de rendu exploser quand on passe de 4 à 5.

Et je ne suis pas à cours de RAM (il reste 4Go de libre pendant le calcul)...

Share this post


Link to post
Share on other sites

Je me cite sur le tuto:

> "Par exemple si je calcule l’image 5 et que mon interpolate frame et à 2, il va melanger les .vrmap des images 3,4, 5, 6et 7 pour la calculer."

Du coup, en mettant 5, tu t'assures qu'il n'y aura vraiment aucun flickering mais tu dis a Vray de mélange 11 frames d'IR, 5 avant, la frame en question et les 5 d’après. Bizarre que ca passe d'un coup de 2' à 13' mais normale que ca augmente.

Share this post


Link to post
Share on other sites

Salut !

Me revoila avec les résultats de mes tests. J'arrive a un bon résultat avec des temps de calcul corrects (7' pour la prepass, 15' pour le rendering, en 1280x720).

Mais j'ai des soucis avec l'option "use camera path", qui me fait exploser mes temps de calcul quand je la coche (quasi doubler le temps pour les prepass) et tripler voire quadrupler le temps de rendering.

Donc j'ai pour l'instant décidé de ne pas cocher cette option, surtout que le résultat sans, ne semble pas flicker outre mesure.

Ci-joint mes settings actuels. Qu'en penses-tu Matt ? Rien cui cloche ? Vois tu des paramètres qu'on pourrait essayer d'optimiser ?

Je pensais faire un test avec Interp. Samples a 10 au lieu de 20 (comme préconisé dans la doc Vray quand on utilise le mode Animation Rendering).

Merci, et bonne soirée,

Mes settings PREPASS :

post-974-13494253823817_thumb.jpg

Settings RENDERING :

post-974-13494253827652_thumb.jpg

Share this post


Link to post
Share on other sites

Salut,

Content que ca avance :)

Le mode Use Camera Path est en fait une option qui indique a Vray la position de la cam tout au long de l'anim. Du coup, les samples calculés conservent leurs positions dans dans la pass d'IR. Une contrainte de calcul en plus pour plus de précision et donc moins de flickering: les temps de rendus grimpent > normal :)

Comme c'est décrit dans l'article du blog sur l'IR Map, l'interp mélange les samples. Donc plus ils le sont moins ils peuvent êtres visible au rendu en revanche, comme d'hab en rendu, plus c'est long a calculer ^^ Pour ce qui est de passer de 10 a 20 ca depends de la scene. Perso je test toujours mes scenes avant de faire les rendus pour voir si ca flick, si je peut baisser le asmpling etc. Choisis 4/5 frames qui peuvent etre problematique et test tes params.

Le reste a l'air correct :)

Juste pour faire ch**r le area a 1.5 et tu refloute en postprod?

++

Share this post


Link to post
Share on other sites

Salut,

Oui ca avance bien en effet, merci a toi ! ;)

Ci-joint mes settings mis à jour. J'ai mis area 1,5 en suivant ton conseil. Mais c'est très léger, j'ai testé pas évident de voir la différence !

Sinon j'ai baissé interp. samples a 10 pour le rendu car ça ne semble pas dégrader la qualité de manière sensible.

Un détail : pour rendu j'ai du remettre "cal. pass interpolation samples" a 15 au lieu de 10 (d'ou le "custom" au lieu de "medium (animation)". Car avec la valeur originale j'obtenais de drôles de résultats quand la caméra était immobile (lenteur, bug de GI sur des objets Forest Pro). Mais c'est un autre histoire, j'ai contacté chaosgroup a ce sujet...

bon dimanche !

post-974-1349425383183_thumb.jpgpost-974-13494253836011_thumb.jpg

Share this post


Link to post
Share on other sites
Guest noceros

Bonjour,

est il possible de profiter des images diffusée sur cette pages? Afin de profiter de votre discution avec les illustrations et vos réglages. merci par avance.

Share this post


Link to post
Share on other sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Who's Online   0 Members, 0 Anonymous, 8 Guests (See full list)

    There are no registered users currently online

×