Jump to content
daltonx

probleme alpha d'objets invisibles

Recommended Posts

Bonjour à tous,

voilà mon problème, je lance un rendu vray avec des arbres qui sont en mode invisible a la camera.

je m'en sert pour les reflets et les ombres uniquement.

donc dans les propriétés de l'objet je decoche visible à la camera.

dans les propriétés vray, je lui colle un alpha -1.

mais voilà, je me retrouve avec des artefacts , des taches noires à certains endroits du feuillage et des effets de transparence ou l'on apercoit tout de même l'arbre en question qui apparait!

Est que Quelqu'un aurait la solution à mon problème SVP?

Merci d'avance

post-898-0-05259700-1349865594_thumb.jpg

post-898-0-42405600-1349865631_thumb.jpg

Share this post


Link to post
Share on other sites

Pourquoi tu colles un alpha ? Perso lorsque j'ai des arbres et que je veux qu'ils soient transparents je décoche invisible comme toi et basta...

Sur ton image typiquement c'est ton alpha qui apparait là...

Share this post


Link to post
Share on other sites

merci de m'avoir répondu,

en fait j'essaye de faire le rendu juste en decochant visible to camera ( dans les propriétés de max)

et j'ai toujours un ghost de mon arbre qui apparait et des artefacts noirs par endroits au niveau des feuillages.

j'ai donc essayé en enlevant également l'alpha dans les vray properties mais rien n'y fait.

si j'utilise des arbes 2D appliqués à des faces, même combat.

je me retrouve avec le contours de mes faces de sprites.

post-898-0-43690700-1349948772.jpg

post-898-0-00213400-1349948773.jpg

Share this post


Link to post
Share on other sites

Essaie de faire la même chose avec une scène simple (une box avec une matière réfléchissante et un sol tout con et une box que tu mets en invisible). Le principal dans ce type de galère c'est de supprimer les problèmes au fur et à mesure. Avec ce type de manip tu vois déjà si ça fonctionne et tu compares avec la scène qui merde...

Ps : j'aime bien ta scène en tous cas, faudrait que tu nous en montre un peu plus une fois que tu l'aura terminée...

Share this post


Link to post
Share on other sites

Salut,

J'avais jamais eu ce problème. Je décochais juste visiible to camera et ça marchait nickel. Et sur un projet sur lequel je bosse actuellement j'ai le même soucis que toi. Ce sont pour des arbres en proxys. J'ai environs 200 arbres et ce ne le fait pas sur tous...C'est assez bizarre..Je ne touche pas à l'alpha, jamais eu besoin de le faire, ça marchait trés bien avant.

Les artefacts apparaissent aussi sur la couche alpha....Mais vue que c'est un projet de crématorium ceci explique peut etre celà!! OUuuuuhhh ;-)

Share this post


Link to post
Share on other sites

Bon,j 'avance un peu plus sur mon problème.

Pour les artefacts noirs j'ai trouvé, il faut augmenter le max transp levels dans les reglages de vray (global switches)

en passant de 50 à 500 , il n'y a plus d'artefacts.

Bon, ça c'est fait mais il me reste toujours ces fichus ghosts !

je me retrouve toujours avec la silhouette de mon proxy.

j'ai envie de pleurer... :oops:

post-898-0-08727600-1350232551_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour,

Je me permets de remonter ce post car je rencontre exactement le même problème et je me demandais si entre temps une réponse avait été trouvée ?

Pour ma part c'est un export Revit qui pose problème.

Ce que j'ai pu constater c'est que ces ghosts apparaissent quand l'objet ainsi caché comporte des faces qui se chevauchent ou qui sont très proches les unes des autres (enfin en tout cas dans mon image). C'est d'ailleurs uniquement ces faces que j'aperçois sous forme de points gris.

En supprimant les polys en double il n'y a plus de soucis mais c'est bien trop fastidieux surtout que ces faces ne se voient pas en temps normal (ex une jonction entre un mur et une fenêtre).

Des pistes ?

Share this post


Link to post
Share on other sites

Est ce qu'il sagit du même problème que moi?

je decoche "visible to camera" sur mes arbres dans les propriétés pour garder uniquement les reflets

mais quand je shoot, il me reste des ghosts.

Si quelqu'un a la solution... je suis en plein concours, et ça m'aiderait....vraiment...

THX d'avancepost-898-0-84583700-1351151751_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour,

Il s'agit du même problème, en cherchant à rendre un objet invisible tout en gardant son impact sur la scène j'ai décoché visible to camera. La différence c'est que je n'ai besoin que des ombres, visible to reflexions et refractions sont décochés.

J'ai essayé ton astuce mais ça n'a rien changé car à la base il n'y avait pas d'artéfacts noirs, juste les ghosts.

Share this post


Link to post
Share on other sites

En fait, j'avais activé Vraytoon pour récupérer les traits, en excluant les arbres, mais c'est de là que ça venait.

en virant vraytoon tout simplement , plus de ghosts...

Des fois, je suis pas fier.... :?

Share this post


Link to post
Share on other sites

En vérité il s'agit d'un bâtiment et non d'un arbre, mais il me pose lui aussi des problèmes de ghosts (sans vraytoon).

Je souhaite rendre un "plan 3d" tout en conservant les informations sur les ombres et la lumière. Mon bâtiment est donc vu du dessus, coupé en deux à une certaine hauteur. C'est la partie supérieure qui est rendue invisible et qui me pose soucis.

Je joins des images : on les voit surtout dans la partie en bas de l'image 1, sur le parquet et contre les fenêtres en haut. Sur l'image deux c'est pour que vous compreniez mieux ce qui se passe : on voit le bâtiment coupé en deux, la partie du étant normalement invisible (cf object properties)

ghost_02.jpgghost_04.jpgghost_05.jpg

Share this post


Link to post
Share on other sites

Je suis novice dans le domaine, j'ignorais l'existence de cette fonctionnalité sur les caméras. Si ça me permet d'avoir une coupe rigoureuse à 2m de hauteur et accessoirement de rendre la tranche des éléments coupés en blanc ce serait top ! Je vais faire des essais

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...