Jump to content
Flow

Reflections et Specular non consistants entre les frames

Recommended Posts

Bonjour à tous. J'ai un souci avec Vray. Je bosses sur une animation et les reflections de sources de lumière ainsi que la specular render pass ne sont pas consistants entre les frames. Elles ''bougent" ou disparaissent entre les différentes frames. J'ai l'impression que ce n'est pas juste du flickering. Quelqu'un a une idée?

Merci.

Edited by Flow

Share this post


Link to post
Share on other sites

Bonjour @Nicolas Caplat, @Miaz3. Oui j'utilises du denoising mais avec le Denoiser tool. Les problèmes constatés sont présents aussi bien avec les rendus raws qu'avec les versions denoisées. En faisant quelques tests hier j'ai remarqué que le noise Threshold avait quelque chose à avoir avec mon problème. J'utilise 0.035 ( qui est bas mais avec le denoising il n'y a pas de soucis pour un still) - De plus je ne denoise que les pass de Reflection, GI et Lighting donc pas trop de perte de détails - Avec un Threshold de 0.01 voir 0.005 le problème est reduit mais ne disparait pas.

Voici ce que j'ai déjà essayé et qui n'a pas marché:

- Changer le color mapping ( je suis normalement en Linear multiply)

- Clamp output à 1

- Activé Sub-pixel mapping

- Mode screen

Ce qui donne des résulats interessants (mais j'ai l'impression de juste contourner le problème):

- Diminuer le Specular contribution du sun à 0.2. Bien évidemment les rendus perdent en spécularité mais on ne le remarque pas trop

- Supprimer des IES et les remplacer par un vray plane

- Enfin ce sur quoi je compte le plus, je suis passé en BF+LC.

LC

    - Preset: Animation

    - Subdivis: 2000

    - Sample size: 0.01

    - Scale: Screen

    - Retrace activé

    - Camera path activé

    - Mode: Flythrough

Noise threshold ramené à 0.02.

J'ai rendu 10 frames cette nuit. Là je vais voir ce que ça donne.

PS: @Miaz3 j'utilise un Vray Sun pour lit la scène. Par contre j’ai bien un hdri plaqué à une sphère (+self-illumination) pour les reflections.

Share this post


Link to post
Share on other sites
2 minutes ago, Nicolas Caplat said:

J'y pense, tu as activé le Lock Noise Pattern dans les paramètres DMC ?

Non Lock Noise Pattern  désactivé.

Share this post


Link to post
Share on other sites
1 hour ago, Nicolas Caplat said:

Ou plutôt des subdivs insuffisantes pour ton AA ...

Tu as un RE Sample Rate pour vérifier ça ?

Non je n'ai pas rendu la Sample Rate. Je vais le faire.

Share this post


Link to post
Share on other sites

Bonsoir @Nicolas Caplat

Voici ce que me donne le Sample Rate.

Noise threshold: 0,01

_01.VRaySampleRate.thumb.jpg.11fe76ec34a5ac61211657405188167b.jpg

 

Noise threshold: 0,02

_02.VRaySampleRate.thumb.jpg.53e9cf17688c158f1776fe8ca216a39f.jpg

 

Noise threshold: 0,05

_05.VRaySampleRate.thumb.jpg.66638983c98eaf394f606ac249ced605.jpg

 

Aussi, y a t'il une raison particulière pour laquelle les buckets de vray traînent autant sur les carrosseries des véhicules? Je n'arrive pas à résoudre à accepter que ce soit normal.

Share this post


Link to post
Share on other sites

Ok.

Et si tu passes ton AA à 1-48, avec un noise threshold à 0.005, il ressemble à quoi ton sample rate ?

Ce qui est étrange, c'est que ce que tu montre est très/trop homogène je trouve, on ne sent pas le boulot adaptatif du sampler.

En même temps, je suis plutôt rouillé sur VRay alors bon ....

Share this post


Link to post
Share on other sites
8 minutes ago, Nicolas Caplat said:

Ok.

Et si tu passes ton AA à 1-48, avec un noise threshold à 0.005, il ressemble à quoi ton sample rate ?

Ce qui est étrange, c'est que ce que tu montre est très/trop homogène je trouve, on ne sent pas le boulot adaptatif du sampler.

En même temps, je suis plutôt rouillé sur VRay alors bon ....

Je vais essayer le 1-48. J'ai aussi trouvé que c’était étrange quand j'ai comparé au doc de vray...

Share this post


Link to post
Share on other sites

C'est mieux ! Et au niveau temps de calcul ?

Le truc, c'est que tes spots encastrés ne semblent toujours pas bien pris en compte ... 

Tant qu'à faire, essaie aussi en 1-64, en baissant encore le threshold. 

C'est d'autant plus curieux que ta scène n'a rien d'atypique. 

Share this post


Link to post
Share on other sites
11 hours ago, Nicolas Caplat said:

C'est mieux ! Et au niveau temps de calcul ?

Le truc, c'est que tes spots encastrés ne semblent toujours pas bien pris en compte ... 

Tant qu'à faire, essaie aussi en 1-64, en baissant encore le threshold. 

C'est d'autant plus curieux que ta scène n'a rien d'atypique. 

- J'ai un temps de rendu de 40 min, ce qui est trop.

- 1-64 avec un threshold de 0.005 ne change pas grand chose. Le temps de rendu étant déja trop long je n'ai pas essayé un threshold plus bas.

Pour avoir des temps de rendu plus acceptable j'ai diminué la taille de l'image, 1920x1080 à 1280x720. J'ai un nouveau temps de rendu de 20 min avec calcul du LC,IM et 15 min avec LC et IM pré calculés.

Quelques tests que j'ai fait (avec IM et LC précalculés):

 

AA 1-48

Noise threshold 0.005

Temps de rendu 15 min

SampleRate

_005.VRaySampleRate.thumb.jpg.8f0bfdaa2fad68bcbfc22f973e70bdd8.jpg

NoiseLevel

_005.VRayNoiseLevel.thumb.jpg.ca25882bacebf2954c4d631864a47969.jpg

 

AA 1-48

Noise threshold 0.004

Temps de rendu 18 min

SampleRate

_004.VRaySampleRate.thumb.jpg.c85648605b043645a322afdd111bb136.jpg

NoiseLevel

_004.VRayNoiseLevel.thumb.jpg.b04a5a6b219152cf1f53a9158c5168df.jpg

 

AA 1-48

Noise threshold 0.003

Temps de rendu 23 min

SampleRate

_003.VRaySampleRate.thumb.jpg.3761552fcd83f6538b473fe0d7e05dd7.jpg

NoiseLevel

_003.VRayNoiseLevel.thumb.jpg.90372ff01063e944ddbf5c03b5a5de1f.jpg

 

Je penche pour un AA 1-48 et Noise threshold 0.004. Je vais rendre quelques frames et voir ce que ça donne.

Share this post


Link to post
Share on other sites
36 minutes ago, Choupi said:

Je me pose la question du HDRI, je suis rouillé aussi, mais la qualité de ton BG ne pourrait pas jouer sur ça?

Bonsoir Choupi. Je n'utilise pas d'hdri pour éclairer la scène, juste un VraySun. Le BG est juste une map appliquée à une sphère. Pour vérifier, j'ai le même problème en cachant le BG.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Who's Online   0 Members, 0 Anonymous, 21 Guests (See full list)

    There are no registered users currently online

×
×
  • Create New...